FATAL ERROR:undefined method LibertyAttachable

Igor Crljenica
Joined: 03 Mar 2008

FATAL ERROR:undefined method LibertyAttachable

Posted:17 Apr 2008 (13:03 UTC)
In the Liberty Attachments, when I click the button next to each attachment that checks attachment usage I get the following error:

Fatal error: Call to undefined method LibertyAttachable::scanForAttchmentUse() in /var/www/bitweaver/liberty/attachments.php on line 41

I have two test sites as well as a live site and they all get this error so it has nothing to do with one bad installation? Anyone else experiencing the same thing. I'm starting to think that this is a bug in the latest release. Any help is appreciated.
JJ
Joined: 16 Apr 2008

Re: FATAL ERROR:undefined method LibertyAttachable

Posted:17 Apr 2008 (16:17 UTC)
Hi Igor, I tried to duplicate the problem but I don't know where to look under admin menu. I'm using R2 and I choose liberty->list all content, but I don't see where to check for usage? Sounds like a bug.
Anonymous

Re: FATAL ERROR:undefined method LibertyAttachable

Posted:18 Apr 2008 (16:50 UTC)
Let's say that yo log in as Administrator on your site. In the My"sitename" drop down menu click on My Files. This opens Liberty Attachments. This should list all attachments that you have uploaded as an administrator or you can search attachments for any user of the site.
Once you see an attachment (image in my case) under Actions there is an image (symbol for attachments) that you can click on to check attachment usage. As soon as I click on that I get my error.