Upgrade from 2.1 to 2.5 and 2.6RC2 fails

mmln
Joined: 22 Jun 2008

Upgrade from 2.1 to 2.5 and 2.6RC2 fails

Posted:14 Apr 2009 (19:31 UTC)
Trying to upgrade from 2.1 to 2.5 and it fails, same issue occurred when upgraded to 2.6RC2 as well.

After database (mysql) copy and director refresh and config_inc.php changes when I login it took me to install(upgrade) step-4 page:

It has warning at top


Warning: fopen(/var/tmp/graph_MwSjTr.cmapx) function.fopen: failed to open stream: No such file or directory in /home/...../public_html/upg2/util/pear/Image/GraphViz.php on line 210


Notice: Undefined variable: data in /home/...../public_html/upg2/util/pear/Image/GraphViz.php on line 218


Warning: Cannot modify header information - headers already sent by (output started at /home/...../public_html/upg2/util/pear/Image/GraphViz.php:210) in /home/...../public_html/upg2/install/BitInstaller.php on line 158


Ignored the above warning and went ahead clicked 'Upgrade Packages'.

Now the below fatal error appears..cannot move forward.


Fatal error: Cannot redeclare data_translated_help() (previously declared in /home/...../public_html/upg2/liberty/plugins/data.translated.php:48) in /home/...../public_html/upg2/languages/liberty_plugins/data.translated.php on line 55
spiderr
Profile Picture
Joined: 08 Feb 2004

Re: Upgrade from 2.1 to 2.5 and 2.6RC2 fails

Posted:15 Apr 2009 (01:47 UTC)
It appears to you have overlaid files and did not use a clean distro.

Delete /home/...../public_html/upg2/liberty/plugins/data.translated.php as it was moved to the languages package.

Repeat as necessary for other plugins. Or, just delete *everything* in that folder, and copy the latest liberty/plugins folder
mmln
Joined: 22 Jun 2008

Re: Upgrade from 2.1 to 2.5 and 2.6RC2 fails

Posted:15 Apr 2009 (16:34 UTC)
Excellent...deleting everything and copying from 2.5 plugin folder worked.