Unable to Install - Parse Error

Leo
Joined: 29 Apr 2009

Unable to Install - Parse Error

Posted:29 Apr 2009 (22:28 UTC)
Trying to install under PHP 4.3.2. Deleted and re-uploaded entire package, file permissions set according to the docs.

Parse error: parse error, expecting `')'' in /home/.../liberty/LibertyContent.php on line 819

Fatal error: Class libertyattachable: Cannot inherit from undefined class libertycontent in /home/.../liberty/LibertyAttachable.php on line 39


It doesn't look like there really is a missing ).

Any ideas?
Lester Caine
Joined: 24 Apr 2004

Re: Unable to Install - Parse Error

Posted:01 May 2009 (07:15 UTC)
OK 4.3.2 really is quite old (6 years or so) and it will depend also on having compatible versions of your database engine for that version of PHP. You should really be looking to switch to PHP5.

That said - since it may be relevant to - bw should still be OK on PHP4. So
Which Database?
Are you simply installing ALL packages. That is not recommended ( and I think we should default to none selected so that a quick install will work ).

Also what point in the install process are you getting the error - which does not make sense at the moment.
Leo
Joined: 29 Apr 2009

Re: Unable to Install - Parse Error

Posted:05 May 2009 (15:22 UTC)
MySQL is also very old: 3.23.58

I'm extremely reluctant to upgrade either PHP or MySQL in case it breaks any of the more important things that currently work on the server.

The error occurs right away. I ran the requirements check (passed the essentials), created a database, uploaded the files, CHMODed the file and folders indicated in the installation guide, navigated to install.php and that's where things ground to a halt.

I doubt that the database is at fault, since BW doesn't even know of its existence yet. When you ask if I'm installing all packages, I assume that this is an option that comes later in the installation process?
Lester Caine
Joined: 24 Apr 2004

Re: Unable to Install - Parse Error

Posted:06 May 2009 (14:30 UTC)
It does sound as if something that has been added recently is not compatible with PHP4.3 but I don't understand why the installer would be accessing that area of code when it's first step is to check you system configuration, but it does seem to be something to do with the services setup. Which does not exist at that point.

I think everybody here has moved on to at least PHP4.4 so testing on older versions is not happening - but I will stick a flag up on IRC ...
Leo
Joined: 29 Apr 2009

Re: Unable to Install - Parse Error

Posted:06 May 2009 (18:22 UTC)
Thank you Lester.
Luis
Joined: 20 May 2009

Re: Unable to Install - Parse Error

Posted:20 May 2009 (01:15 UTC)
Howdy
has anyone come up with a solution to this problem? I seem to have the same error on installation.
Lester Caine
Joined: 24 Apr 2004

Re: Unable to Install - Parse Error

Posted:20 May 2009 (07:02 UTC)
On PHP4.3?

None of us here are running PHP4 now, so testing for problems is a little bit difficult. In fact even the PHP developers are adding things that are simply not compatible with PHP4 which does not help.
I think we have probably reached the point where we HAVE to freeze a release that is suitable for PHP4, which may well have been R2.5 :(

That said, it's only the odd little thing that is causing a problem with PHP4 so short term it should be possible to get around them. But as I said previously - not even sure why the installed would be accessing the services area, that is not needed to install.
Anonymous

Re: Unable to Install - Parse Error

Posted:20 May 2010 (04:19 UTC)
Hi, cannot get around this installation problem either. I am using php 4.4.9. My host does not give me the ability to upgrade. Any solution?

Many thanks.
Tom

Re: Unable to Install - Parse Error - Problem Solved

Posted:20 May 2010 (14:00 UTC)
It looks like I solved my own problem. Every time you get the above error message (they are found throughout the various packages), you need to remove the & from any bit of code that looks like the following:

&$pParamHash = NULL

So change it to look like this:
$pParamHash = NULL

If there is no "= NULL" assignment, leaving the & in works ok.

I had to make the change in the following places:

LibertyContent.php
Lines 819 and 1066

LibertyTag.php
Line 657

iLike.php
Line 285

There will probably be others in other packages. Perhaps someone should report this to the head honchos? I am not a frequent user or contributor so I don't know who to tell.

Good luck to everyone, I am excited to use this software.
pozdoz

Re: Unable to Install - Parse Error

Posted:03 Jun 2011 (15:12 UTC)
Thanks Tom this fix worked for me too - PHP4.4.9