Blank screen with error after updating 2.5 to 2.6.1

traveler

Blank screen with error after updating 2.5 to 2.6.1

Posted:16 May 2009 (12:53 UTC)
Blank screen with error after updating 2.5 to 2.6.1

Hello guys, I tried to update my bitweaver installation today but I got an error.
I took a backup of /kernel/config_inc.php and /storage, I deleted all the folders and uploaded the new packages from the zip file. I then restored the config file and storage and tried to visit my site in order to complete the procedure.

I get a blank white page with the error:
Parse error: syntax error, unexpected '=', expecting ')' in /homepages/44/d243791111/htdocs/site/wiki/bitweaver/liberty/LibertyContent.php on line 819

Any ideas/suggestions?
xing
Joined: 07 Mar 2004

Re: Blank screen with error after updating 2.5 to 2.6.1

Posted:17 May 2009 (05:22 UTC)
can you please view that file and copy / paste at least about +/- 10 lines from that file in here? (make sure you put the code into a {code}...{/code} block.

x

PS: in future always follow the bitweaverUpgrade outlined. never delete any files until the upgrade process is complete and you're sure that everything is working. you always need a way to revert in case something goes wrong.
Lester Caine
Joined: 24 Apr 2004

Re: Blank screen with error after updating 2.5 to 2.6.1

Posted:17 May 2009 (05:41 UTC)
Actually the problem here is a piece of PHP5 only code that is now being used. The line quoted will not work with PHP4 ...
We probably need to make a decision on dropping PHP4, but that needs a working PHP4 we can freeze at, and there are a few security fixes that would need to be back ported to R2.5