installer wont run :(

sander
Joined: 17 Dec 2010

installer wont run :(

Posted:17 Dec 2010 (21:44 UTC)
hi all,

I am trying to install bitweaver on my buffalo NAS.

i get the error message :

__''Not enough memory
The memory limit of "" is not high enough to run the bitweaver installer. Please up the memory limit in you php.ini to at least 16M to install and run bitweaver.''__

however, in my php.ini file. the memory limit is set to 128 Mb.

;;;;;;;;;;;;;;;;;;;
; Resource Limits ;
;;;;;;;;;;;;;;;;;;;

max_execution_time = 30 ; Maximum execution time of each script, in seconds
max_input_time = 60 ; Maximum amount of time each script may spend parsing request data
;max_input_nesting_level = 64 ; Maximum input variable nesting level
memory_limit = 128M ; Maximum amount of memory a script may consume (128MB)

anybody got any idea what might be causing this.

the PHP version of webserver on the NAS is 5.2.10

thx
harimix
Joined: 11 Dec 2010

Re: installer wont run :(

Posted:19 Dec 2010 (09:33 UTC)
Some installations have several php.ini maybe you checked a php.ini that is not the one loaded actually.

Check the effective configuration of your php installation with phpinfo. E.g. load yourServer/kernel/admin/phpinfo.php in your browser.

In the resulting page check the actual memory_limit.
you also can see the location of the php.ini that is acutally loaded.
Lester Caine
Joined: 24 Apr 2004

Re: installer wont run :(

Posted:19 Dec 2010 (10:51 UTC)
Had you said you were using PHP5.3 it is possible that a change to the way PHP handles some of the settings, but as harimix says ... check phpinfo() to confirm settings.
sander
Joined: 17 Dec 2010

Re: installer wont run :(

Posted:19 Dec 2010 (14:12 UTC)
thx for the info. I will see if i can find that file you mentioned.

problem is , that the webserver is embedded in my NAS.

I honestly have no idea how to connect to that path you mentioned. when i log into the NAS i can select a TAB called webserver but it has just the basic. like turn on/off and portnr. Also this is where the php.ini file is displayed . but it doenst say where it is stored. it must be ahidden folder because when i browse the nas i cant find anything.

I installed a different CMS and there during install it said that i have 128 Mb.
Lester Caine
Joined: 24 Apr 2004

Re: installer wont run :(

Posted:20 Dec 2010 (19:37 UTC)
phpinfo() is a page that you access from the web.

Create a file with the following three lines ...
<?php
phpinfo();
?>

And save it as phpinfo.php in your root web directory. It's almost essential for managing and checking PHP operation from the web.